Eversense CGM App*

  • iPhone 6, 6s, 7, 7 Plus, 8, 8 Plus, X, XS, XS Max, XR, 11, 11 Pro, 11 Pro Max, 12, 12 Pro, 12 Pro Max, 12 Mini, 13, 13 Pro, 13 Pro Max, 13 Mini
  • iPod Touch 6th Generation
  • iPad iPad Mini (Retina)
  • ASUS ZenFone 3 Zoom
  • Google Pixel 2 XL, Pixel 3, Pixel 3 XL, Pixel 3a, Pixel 4, Pixel 4 XL, Pixel 5
  • Great Call Jitterbug Smart2
  • Huawei Mate 20 Lite, Mate 20 Pro, Mate 20 X, P30, P30 Pro
  • HMD Global Nokia 6.1, Nokia 9 Pure View
  • LG G8 ThinQ, 35 ThinQ, 40 ThinQ
  • Motorola Moto E5, Moto G7 Power, e4 Plus
  • One Plus 6T, 7 Pro, 9 Pro
  • Samsung Galaxy Note 8, Galaxy Note 9, Galaxy S7, Galaxy S8, Galaxy S8+, Galaxy S9, Galaxy S9+, Galaxy S10, Galaxy S10 Plus, Galaxy S10e, Galaxy Note 10, Galaxy Note 10+, Galaxy S20FE 5G, Galaxy S20 5G, Galaxy S20 Plus 5G, Galaxy S20 Ultra 5G
  • Xiaomi Redmi Note 10, MI 10 T
  • Apple Watch (5.X.X to 8.X.X)

To help ensure an optimal experience with your Eversense system, we recommend you disable automatic updates on your mobile device. Some operating system updates may result in a need for a supporting update to the Eversense Mobile Apps. Once we have verified compatibility of new operating systems with Eversense, we will post them to this web page. Additionally, we recommend not using beta versions of operating systems.

Watch Series 2, Watch Series 3, Watch Series 4 (40 mm and 44mm), Watch Series 5 (40mm and 44mm)

Eversense Now App*

  • iPhone iPhone 6, iPhone 6s, iPhone 7, iPhone 7 Plus, iPhone 8, iPhone 8+, iPhone X, iPhone XS, iPhone 11, iPhone 12, iPhone 13, iPhone 13 Pro, iPhone 13 Pro Max, iPhone 13 mini
  • Xiaomi Redmi Note 10, MI 10 T
  • Samsung Galaxy Note 9, Galaxy S9, Galaxy S9+, Galaxy S10, Galaxy S10e, Galaxy Note 10+ 5G, Galaxy Note 20 Ultra 5G, Galaxy S20 FE 5G, Galaxy S20 Ultra 5G, Galaxy S20+ 5G, Galaxy S21 Ultra 5G, Galaxy S21+ 5G
  • Google Pixel 5
  • One Plus 9 Pro

To help ensure an optimal experience with your Eversense system, we recommend you disable automatic updates on your mobile device. Some operating system updates may result in a need for a supporting update to the Eversense Mobile Apps. Once we have verified compatibility of new operating systems with Eversense, we will post them to this web page. Additionally, we recommend not using beta versions of operating systems.

Eversense Data Management System*

  • Internet Explorer (v11)
  • Google Chrome (v73, v72, v71, v70, v69, v68)
  • Firefox (v65, v64, v63, v62, v61)
  • Safari (v12, v11.1, v10.1)
  • MS Edge (v17)

* Subject to change please visit this page regularly for updates.
† To verify your iOS model type, click here.

MKT -001550 Rev1